JP1 Remotes Forum Index JP1 Remotes

FAQFAQ SearchSearch 7 days of topics7 Days MemberlistMemberlist UsergroupsUsergroups RegisterRegister
ProfileProfile Log in to check your private messagesLog in to check your private messages Log inLog in

RMIR "no remotes found" resolved

Post new topic   Reply to topic    JP1 Remotes Forum Index -> JP1 - Software
View previous topic :: View next topic  
Author Message

Joined: 09 Mar 2005
Posts: 14

PostPosted: Wed Jan 11, 2017 12:09 pm    Post subject: RMIR "no remotes found" resolved Reply with quote

I wanted to share what I found when trying to get a particular remote working. I suspect what I found may be useful to others.

Brief background: most of my remotes are JP1 remotes and I use the parallel connector for them. But I have one Comcast 1067 remote which appears to be a JP1.2. To work with that, I bought a DIYGADGET JP1.1/1.2 Serial Cable ages 5 years ago, updated the remote, and it's been working fine since.

Yesterday I finally got to some long needed updates. I updated a handful of JP1 remotes and then got to the Comcast 1067. I dug out the serial cable and hooked it up to the serial port on the laptop dock and updated the interface to point to COM3, the dock's port. "No remotes found!".

Oh, right, I think this cable and remote combination end up with the wire over the battery compartment instead of away like my other cable and remotes. "No remotes found!" Hmm, maybe I had it right the first time? I switched it back. "No remotes found!"

Oh, I remember. I used a USB to serial adapter. Dug it out from the bottom of the drawer and hooked it up. It's a "Trendnet TU-S9" but it shows up in Device Manager as a Prolific. "No remotes found!" And now I don't have any memory about which orientation the cable goes so each try will involve turning the plug around. "No remotes found!"

What if I switch the Interface to specifically call out the port? Let's see, COM5 is shown in device manager. "No remotes found!" Turn plug. "No remotes found!"

Hmm, maybe a hardware problem. I took apart the JP1.1/1.2 cable and found one of the conductors was loose from the board. But I remembered that one of the wires isn't needed for one of the connection types so I assumed that was probably why that wire was not connected.

Okay, at this point I'm pretty confident that I'm using the same hardware I used last time. But what about the software? Yes, it is the same RMIR "v2.0.3Alpha28build6" version I used last time. But I guess I could try upgrading that. I installed v2.0.3build12". "No remotes found!" Turn plug. "No remotes found!"

I finally found a post here that talked about looking for an error in the rmaster.err file. I remembered doing this before. The error was saying that the port was null, but it was always right after the port wasn't null. So, when I was testing COM5, it would show the following:
Interface Name = JP1.X Serial
Port Name = COM5
Testing interface: JP1.X Serial
Interface matched.  Trying to open remote.
Port Name = NULL
Failed to open

Hey, but wait a minute. The LibraryLoader statements above this part all were hitting the "Windows-x86" directory. And I'm running Windows 7 64-bit. That would definitely be a problem. Let's see... Oh, after installing the new version, I didn't run the Setup.vbs script and I was launching using an old shortcut which pointed to Java 1.7. I ran the script which created a new shortcut using java 1.8. I used the new shortcut to launch and tested again. The rmaster.err file this time showed that it was loading from "Windows-amd64". But still "No remotes found!" Turn plug. "No remotes found!"

Which wire is it that is supposed to be clipped again for JP1.3? Wire #5. But the loose wire in my connector was all the way to one side. That seems likely to be either #1 or #6 and not #5. I soldered the broken conductor back into place. "No remotes found!" Turn plug. "No remotes found!"

Maybe battery related? I tried removing the batteries. And I tried new batteries. In both cases: "No remotes found!" Turn plug. "No remotes found!"

At some point I noticed that in some cases, when I removed the connector on the remote, the light on the remote would blink. Other times it would not and then the remote was dead until I pulled a battery and sometimes it would be even better if I pressed and held any remote button to drain the remote completely. So after "clearing" the remote like that I tried again. "No remotes found!" Remove plug, clear remote, turn plug. "No remotes found!"

I tried connecting to the remove via a terminal program. I set connection to 9600/8/n/1. And it said I connected. But I discovered that it would say I connected even if there was no remote connected to the cable. So that only shows that the serial interface is active and not whether a remote is connected which isn't really helpful.

What about driver updates? Back to the laptop dock's port in Device Manager and tried updating that driver. Nope, 2012 is the latest version there. How about the USB adapter? Interesting, yes, there's an update for that; pretty recent in fact: Sep 2016. Updated that and tried again. "No remotes found!" Remove plug, clear remote, turn plug. . . . . . It worked!!

Recapping, I needed to fix the cable, upgrade RMIR, run Setup.VBS, upgrade the driver for the USB to Serial adapter, not use the dock's built in serial port, and attach the cable with the cable going "down" over the battery compartment - and if I did it wrong, then I'd need to pop a battery and hold a remote button to clear the remote before trying the right way. Or at least I needed to do many of those things and given how much time I've taken just getting to this point, forgive me for not going back and testing out each piece to see what was needed and what wasn't!
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic       JP1 Remotes Forum Index -> JP1 - Software All times are GMT - 5 Hours
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group
Get Smart! the band's official homepage Rockabilly Central