JP1 Remotes Forum Index JP1 Remotes


FAQFAQ SearchSearch 7 days of topics7 Days MemberlistMemberlist UsergroupsUsergroups RegisterRegister
ProfileProfile Log in to check your private messagesLog in to check your private messages Log inLog in

jiangsu cable tv remote
Goto page Previous  1, 2
 
Post new topic   Reply to topic    JP1 Remotes Forum Index -> JP1 - Protocol Decodes
View previous topic :: View next topic  
Author Message
mdavej
Expert


Joined: 08 Oct 2003
Posts: 3793

PostPosted: Wed Jun 17, 2015 9:20 am    Post subject: Reply with quote

chuliu wrote:
I am assuming the code.s3c80=xxx code has to do with the mid-frame burst.
That's the assembler that defines the entire protocol, not just one aspect of it. To understand it, you have to learn s3c80 assembler.
Back to top
View user's profile Send private message
chuliu



Joined: 04 Dec 2010
Posts: 313
Location: Hong Kong

PostPosted: Thu Feb 23, 2017 11:44 pm    Post subject: Reply with quote

hi I encountered a similar remote with mid-framebust and the reapeting frame is a lead in and one on, which is very similar to jiangsu.

It is a ocn es200 stb (shanghai ocn cable and model is longjing tech es200)

I uploaded the ict to diagnosis area here:
http://www.hifi-remote.com/forums/dload.php?action=file&file_id=14435

I noticed that not only one and zero defined in jiangsu are the same as those in ocn, device bytes of 3 and command byte of 2 are the same. Also, the starting bit of midframe burst is also the same after bit 24.

Can someone take a look at why this rmdu doesn't work?

http://www.hifi-remote.com/forums/dload.php?action=file&file_id=14436
It is modified from jiangsu protocol, so one will need to add jiangsu protocol to protocol.ini.


Before I tried to modify the jiangsu protocol, I actually used protocol builder to build a protocol with mid frame burst equaled to lead in frame. This is done with

BITS W7.3
JP $0146

But the resulting signal only has 1 signal (which is the same as the original learn) and no repeating signal, unlike the original signal with repeating (lead in, one on, silence)

I think that's why it doesn't work.

The modified jiangsu rmdu is really close imo, just the lead out silence is slightly different.

I don't know why it doesn't work.

Thanks,
Back to top
View user's profile Send private message
3FG
Expert


Joined: 19 May 2009
Posts: 3241

PostPosted: Fri Feb 24, 2017 1:05 am    Post subject: Reply with quote

Basically it looks like it shoots the correct signals. However, the exact durations may be slightly wrong.

I'd try changing
Code:
 43 8B 32 8B 16 CF 44 08 08 01 11 02 12 01 11 00 FA D2 DC 07 1C 03 70 FF FF FF 19 77 77 F6 01 46 F6 01 0A 7B 01 AF E6 20 06 E6 21 E0 E6 28 C0 57 76 46 29 01 8D 01 46


Code:
43 8B 32 8B 16 CF 44 08 08 01 11 02 12 01 11 00 FA D2 DC 06 FE 03 57 FF FF FF 19 77 77 F6 01 46 F6 01 0A 7B 01 AF E6 20 06 E6 21 E0 E6 28 C0 57 76 46 29 01 8D 01 46
This will shorten up the durations of the lead in and mid frame burst.
Back to top
View user's profile Send private message
chuliu



Joined: 04 Dec 2010
Posts: 313
Location: Hong Kong

PostPosted: Fri Feb 24, 2017 1:44 am    Post subject: Reply with quote

https://drive.google.com/open?id=0B8aHzss3qrAHcWh5QXhONThpZnM

https://drive.google.com/open?id=0B8aHzss3qrAHMjdfMVp1UVBzdHM

The above is the wave form of power button of the original remote.
The below one is that of the upgrade file modified from jiangsu protocol.
I know that the lead out silence and the silence after the first signal segment are different. Do they make the signal not work?

Or should I consider if the stb is hung or ir blaster not set up correctly?
It is a slingbox 500 so I doubt the ir blaster is not set up as 500 has built in ir emitters.
Back to top
View user's profile Send private message
chuliu



Joined: 04 Dec 2010
Posts: 313
Location: Hong Kong

PostPosted: Fri Feb 24, 2017 9:01 am    Post subject: Reply with quote

chuliu wrote:
hi I encountered a similar remote with mid-framebust and the reapeting frame is a lead in and one on, which is very similar to jiangsu.

It is a ocn es200 stb (shanghai ocn cable and model is longjing tech es200)

I uploaded the ict to diagnosis area here:
http://www.hifi-remote.com/forums/dload.php?action=file&file_id=14435

I noticed that not only one and zero defined in jiangsu are the same as those in ocn, device bytes of 3 and command byte of 2 are the same. Also, the starting bit of midframe burst is also the same after bit 24.

Can someone take a look at why this rmdu doesn't work?

http://www.hifi-remote.com/forums/dload.php?action=file&file_id=14436
It is modified from jiangsu protocol, so one will need to add jiangsu protocol to protocol.ini.


Before I tried to modify the jiangsu protocol, I actually used protocol builder to build a protocol with mid frame burst equaled to lead in frame. This is done with

BITS W7.3
JP $0146

But the resulting signal only has 1 signal (which is the same as the original learn) and no repeating signal, unlike the original signal with repeating (lead in, one on, silence)

I think that's why it doesn't work.

The modified jiangsu rmdu is really close imo, just the lead out silence is slightly different.

I don't know why it doesn't work.

Thanks,




forgot to add the button names:

power
service
mute
up
down
left
right
back
info
ok
tv
red
green
yellow
blue
1
2
3
4
5
6
7
8
9
0
*
#

according to ict file sequence.
Back to top
View user's profile Send private message
The Robman
Site Owner


Joined: 01 Aug 2003
Posts: 18563
Location: Chicago, IL

PostPosted: Fri Feb 24, 2017 12:29 pm    Post subject: Reply with quote

chuliu wrote:
forgot to add the button names:

I just added the button names to the file and replaced it.
_________________
Rob
www.hifi-remote.com
Please don't PM me with remote questions, post them in the forums so all the experts can help!
Back to top
View user's profile Send private message Visit poster's website
chuliu



Joined: 04 Dec 2010
Posts: 313
Location: Hong Kong

PostPosted: Sun Feb 26, 2017 8:36 am    Post subject: Reply with quote

For some reason, my friend to whom the ocn stb and sling box 500 belong, reported that the rmdu I posted above actually worked. Maybe he restarted the stb or something. Anyway, thanks.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic       JP1 Remotes Forum Index -> JP1 - Protocol Decodes All times are GMT - 5 Hours
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


 

Powered by phpBB © 2001, 2005 phpBB Group
Get Smart! the band's official homepage Rockabilly Central