JP1 Remotes Forum Index JP1 Remotes

FAQFAQ SearchSearch 7 days of topics7 Days MemberlistMemberlist UsergroupsUsergroups RegisterRegister
ProfileProfile Log in to check your private messagesLog in to check your private messages Log inLog in

Can IR 8.04 program JP2 remotes?

Post new topic   Reply to topic    JP1 Remotes Forum Index -> JP1 - Software
View previous topic :: View next topic  
Author Message

Joined: 24 Dec 2011
Posts: 19

PostPosted: Mon Mar 12, 2018 10:41 pm    Post subject: Can IR 8.04 program JP2 remotes? Reply with quote

Can IR 8.04 be used to program JP2 remotes? I still use IR because I have an old RCA RCU810 remote that uses the parallel cable for programming. I built a USB serial cable (FTDI) to program my JP1.3 Atlas 1056 B01 remote and it works fine using IR 8.04. I also have a JP2 Atlas 1056 B03 remote. When I download it using IR 8.04, it appears to read the data but I get the error "No definition file could be found for this remote".

I have RMIR and use it to program the JP2 remote just fine. I am just curious to know if IR 8.04 is capable of programming JP2 remotes. The error message made me think that it is missing the proper RDF file; I copied and pasted the "201009 (Atlas 1056 B03).rdf" from the RMIR RDF folder to the IR 8.04 RDF folder but I got the same error.

Back to top
View user's profile Send private message
Site Admin

Joined: 20 Mar 2004
Posts: 6952
Location: Florida

PostPosted: Tue Mar 13, 2018 5:53 am    Post subject: Reply with quote

If I recall correctly, IR development and maintenance ended with JP1.3 remotes. Anything after that requires RMIR. After JP1.3 the way things are stored in the E2 area changed dramatically so just copying over the RDF is a no-go.
Remember to provide feedback to let us know how the problem was solved and share your upgrades.

Tip: When creating an upgrade, always include ALL functions from the oem remote, even if you never plan on assigning them to a button. Complete function lists makes an upgrade more helpful to others.
Back to top
View user's profile Send private message Visit poster's website

Joined: 22 Jul 2008
Posts: 2887
Location: Cambridge, UK

PostPosted: Tue Mar 13, 2018 5:57 am    Post subject: Reply with quote

IR 8.04 is incompatible with JP2 remotes. The structure of their data region (the equivalent of the EEPROM of JP1) is very different from that of JP 1.3 and earlier remotes. The RDF specification had to be greatly extended to handle them and IR 8.04 does not understand these extensions. So IR 8.04 cannot program any remotes later than JP1.3.

I see that you still use IR 8.04 to program your RCA RCU810, a JP1 remote, with a parallel interface cable as RMIR does not support the parallel interface on 64-bit Windows. This is about to change, so you can finally put IR 8.04 to rest. I am about to release build 5 of RMIR v2.06 which will include support for the parallel interface for JP1 remotes under 64-bit Windows. I would be grateful if you would try it and confirm that it works for you, please. If you don't want to wait, then see this post. (Scroll down to find my post if that takes you to the top of the page,) The post has a link to the test files for the 64-bit parallel support that you can add to any build of RMIR v2.06. These show up under Help > About as JP1Parallel v0.11. Build 5 of RMIR v2.06 will have JP1Parallel v0.12 but the two are almost identical, the change being only in the 32-bit support.

So please try one or the other on your JP1 remote and let us know how you get on.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic       JP1 Remotes Forum Index -> JP1 - Software All times are GMT - 5 Hours
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group
Get Smart! the band's official homepage Rockabilly Central