JP1 Remotes Forum Index JP1 Remotes


FAQFAQ SearchSearch 7 days of topics7 Days MemberlistMemberlist UsergroupsUsergroups RegisterRegister
ProfileProfile Log in to check your private messagesLog in to check your private messages Log inLog in

RemoteMasterv2.04 crash on upload to device
Goto page Previous  1, 2
 
Post new topic   Reply to topic    JP1 Remotes Forum Index -> JP1 - Software
View previous topic :: View next topic  
Author Message
jonpcar



Joined: 17 Dec 2006
Posts: 18

PostPosted: Wed Dec 07, 2016 2:44 pm    Post subject: Reply with quote

So....some of this is pushing my level of understanding...are these bullets in the ballpark?

1. Graham is creating a 64-bit Java release of RMIR2.04 that should run on 64-bit Windows 8/10, it will include a 64-bit version of JP1USB as part of the build. Question: Should the system default be the 64-bit version of Java version 7 or can it be the latest version?

2. To get the Windows 8/10 operating system to recognize the 64-bit jp1 driver that is being added, one has to go through the GUID process outlined by 3FG in a previous post on this thread

3. Up in the air is whether this will work with varied configurations of EHCI/OHCI, Intel/AMD chips/chipsets, windows8/10/Others, Java Versions

Being able to run these tools on Windows 10 would be a very positive development for me...my Jp1 USB and Jp1 parallel port cables seem to be dying a slow death in any case.
Back to top
View user's profile Send private message
3FG
Expert


Joined: 19 May 2009
Posts: 3240

PostPosted: Wed Dec 07, 2016 3:44 pm    Post subject: Reply with quote

Regarding point 2, I will attempt over the next couple of days to make a *.inf file which may automate the process of associating the GUID with the Delcom cable. It isn't clear whether that is allowed by Windows, but it is worth a try.
Back to top
View user's profile Send private message
mathdon
Expert


Joined: 22 Jul 2008
Posts: 2937
Location: Cambridge, UK

PostPosted: Wed Dec 07, 2016 6:06 pm    Post subject: Reply with quote

On point 1, RMIR 2.04 works with Java 7 or any later version, and with either 32-bit or 64-bit Java. The dll libraries loaded by RMIR are the 32-bit or 64-bit versions according as Java is the 32-bit or 64-bit version. So far, however, there hasn't been a 64-bit version of JP1USB.dll so whether using the Delcom or WinUSB driver, the Java version has needed to be 32-bit to use a Delcom-based cable. The next build of RMIR 2.04 will add the 64-bit build of JP1USB and so allow use of 64-bit Java with a Delcom-based cable. Java 7 is the minimum required, and all I have tested with, but the current latest Java should also be fine.

On point 3, yes there is some uncertainty but we will try to fix any issues that do arise. We rely on users reporting bugs when they occur, as there is no way we can test on all likely equipment configurations.
_________________
Graham
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic       JP1 Remotes Forum Index -> JP1 - Software All times are GMT - 5 Hours
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


 

Powered by phpBB © 2001, 2005 phpBB Group
Get Smart! the band's official homepage Rockabilly Central